Bug #248

Policyd 2.0.12 don`t work with perl 5.10

Added by Micael Sued over 2 years ago. Updated about 1 year ago.

Status:ClosedStart date:2012-05-31
Priority:UrgentDue date:
Assignee:Nigel Kukard% Done:

0%

Category:-
Target version:v2.0.12

Description

Policyd 2.0.12 doesn't work with perl 5.10.

  1. Environment
    - Tested on CentOS 5 (perl 5.8) and CentOS 6 (perl 5.10)
  1. Description

- Using the Quota module with a simple ruleset for testing purposes, the session_tracking table gets updated, but the quotas_tracking table remains untouched. No exception, or errors on the logs, even in debug mode.

- Moving the same version of policyd to a server with perl 5.8, using the same config file and the same ruleset, the tests were okay.

policyd.sql.gz (1.78 KB) Robert Anderson, 2012-06-01 01:20 pm

policyd-data.zip (4.75 KB) André Gustavo Lopes, 2012-06-01 03:36 pm

new_policyd.log (9.1 KB) André Gustavo Lopes, 2012-06-04 12:11 pm

logs.tar.gz (9.13 KB) Robert Anderson, 2012-06-05 01:58 pm

History

#1 Updated by Robert Anderson over 2 years ago

  • File policyd.sql.gz added

Struggling to reproduce this using the following:

Centos 6.2
Perl 5.10.1
MySQL 5.1.61

Attached is a mysqldump of what I'm using to test. Please show a dump of your policyd db from where the tests were run. If there are any more details on the steps taken to reproduce this please log them here.

#2 Updated by Robert Anderson over 2 years ago

  • File deleted (policyd.sql.gz)

#3 Updated by Robert Anderson over 2 years ago

Sorry about that - see this attachment.

#4 Updated by André Gustavo Lopes over 2 years ago

Hi,

Tested the attached dump, on my centos 6.2 server, no change. I can see the debug informatin for RCPT and EOM, but the table quotas_tracking remains untouched.

I have also basically the same version of the mentioned packages (mysql, policyd and perl). I'm trying a long shot here right now, updating all my perl modules via CPAN, considering some of my modules may be stale.

Attached, my db dump, which isn't working as well, and the latest logs,

#5 Updated by Robert Anderson over 2 years ago

Were any changes made to the database before / after you generated the log? What policy is ID 6?

Could you disable policies / quotas you aren't using and make sure the policy you wish to use will match what you're after?

#6 Updated by André Gustavo Lopes over 2 years ago

Hi Robert,
I've uploaded your dump to my database again, "as-is", and took the logs, (attached).

Just 1 policy within, id 6

mysql> select * from policies;
---------------+----------+-------------------------+----------+ | ID | Name | Priority | Description | Disabled |
---------------+----------+-------------------------+----------+ | 6 | Test Policy | 50 | Yet another test policy | 0 |
---------------+----------+-------------------------+----------+

#7 Updated by Robert Anderson over 2 years ago

Attached are my results using the same database..

Could you post the same set of logs for your results?

#8 Updated by Robert Anderson over 2 years ago

Would you be able to give us access to a sandbox environment with the setup you're using so that we can check configuration, etc. ?

#9 Updated by Anthony P V over 2 years ago

Hi,

I too am having the same problem. I am happy to run testing code. I can give ssh access to the server.

Let me know how I can help.

Please note that I am not a programmer.

P.V.Anthony

#10 Updated by Corey Hoffman over 2 years ago

This may be caused by an old version of List::MoreUtils in the EPEL repository:
https://rt.cpan.org/Public/Bug/Display.html?id=77930
https://bugzilla.redhat.com/show_bug.cgi?id=828251

I had the same problem on Redhat 5. It was fixed when installing the latest List::MoreUtils from CPAN.

#11 Updated by Anthony P V over 2 years ago

Did a cpan install of List::MoreUtils and it stated that it is the latest version 0.33.

The problem with the quota module is still there.

#12 Updated by Robert Anderson over 2 years ago

On closer inspection Anthony's issue appears unrelated. Could anyone experiencing this problem with perl 5.10 try Corey's suggestion and provide feedback?

#13 Updated by Nigel Kukard about 1 year ago

  • Status changed from New to Closed

Also available in: Atom PDF